Presentation Screenshots Download Support Development Forum    
   

Welcome to the Community Forum.

Here you can discuss with other users or with the author, suggest new features, report bugs, ask for filters creation or correction, etc. Select the forum you wish to read or post below :

Forum
Forum > Development & Bug report > Bug report for Released Version 1.0.1

Pages : [1] Add a reply
User info Bug report for Released Version 1.0.1
Cyan
Avatar
Feb 6 2010, 5:38 pm
Version 1.0 is finally here !

edit :
And officially available on Mozilla too !
http://addons.mozilla.org/addon/4781/

I'm sure I will have a lot of user's questions in the coming days sweat
I will try my best to reply to all of them.

I will try to work on the FAQ page on this site too.


If you find any bug, even minor problem, please report it here.

Post #1
Edit
Cyan
Avatar
Feb 13 2010, 10:06 am
To release 1.0, Mozilla editor asked me to add a fix if the user didn't defined any filters and try to download a file anyway, as It was not working (of course, no folders was defined).
I added the fix but made a spelling error, and in a hurry didn't recheck the validity of the code, sorry :(

1.0.1 is the new version with the corrected fix.
Please use this one to report any bugs here, not 1.0.0

Thanks
Post #2
Edit
Stefan
Avatar
Feb 13 2010, 1:16 pm
Hi,

I encountered a problem with the latest release 1.0.0 as well as 1.0.1. When I try to open the preferences UI, firefox complains about "XML Parsing Error: undefined entity" on the top level node of the preferences UI. Seems, for some unknown reason, firefox does not find the DTD having the entity definitions. Eventually, the add-on itself does not work anymore, but that may be a follow-up problem.

I reverted to 0.9.3, which works fine.

Cheers, Stefan

Env: Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)
Post #3
Edit
Cyan
Avatar
Feb 13 2010, 1:23 pm
I'm sorry,

in the hurry to correct the file (asked by Mozilla editor) I created another errors >_<
I included beta "de" languages, as it has started to be translated on babelzilla, but it's not completed yet so it must not be included in official release yet.
I forgot to remove it before creating the fixed release.


It's now corrected.
please download the files again (from here, or the new 1.0.1 from mozilla).
Sorry again, And Thank you for reporting it quickly !
Post #4
Edit
Stefan
Avatar
Feb 16 2010, 7:43 am
No worries. Works fine now :)
Thanks,
Stefan
Post #5
Edit
WindFish
Avatar
Feb 17 2010, 5:33 am
After upgrading to 1.0.x, I was no longer able to use "Save image as" from the main context menu and had to downgrade to fix it.
Post #6
Edit
Cyan
Avatar
Feb 17 2010, 9:02 am
I tried version 1.0.0 and 1.0.1 (the one from revision 70 ... I made multiple update with the same version number. Download again the 1.0.1 to be sure).
"Save image as" is working correctly, even with dynamic folder creation.


The filter I used :
Filters Domain
All    
= Regexp.
File name
All    
= Regexp.
Local folder

Now download the bottom image "W3C - xhtml1.0" using right-click "save image as".
It will save into D:\February

Don't try on an avatar from the forum using "save image as", it will not work because it's a redirection script in php to generate the png.
Right-click is not working with "redirection script", that's what the option "disable temporisation" is used for.
If enabled : ASF is working on the real filename (the php script, not the targeted filename)
if disabled : ASF is not working at all. But it lets you save the file using it's real filename.
Post #7
Edit / Delete
Pages : [1] Add a reply

Return to top