Presentation Screenshots Download Support Development Forum    
   

Welcome to the Community Forum.

Here you can discuss with other users or with the author, suggest new features, report bugs, ask for filters creation or correction, etc. Select the forum you wish to read or post below :

Forum
Forum > Development & Bug report > ASF 1.0.1 doesn't save sometimes

Pages : [1] Add a reply
User info ASF 1.0.1 doesn't save sometimes
w1nder
Avatar
Feb 14 2010, 12:12 am
I've been using ASF 0.9.3 with no problems. After upgrading to 1.0.1, when I download a file, sometimes ASF will show the Save To dialog box, but after I click OK, the box disappears and the file isn't saved to disk.

And in Firefox's Error Console, I see this:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIHelperAppLauncher.saveToDisk]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///D:/windows/firefox/components/nsHelperAppDlg.js :: anonymous :: line 492" data: no]
Source File: file:///D:/windows/firefox/components/nsHelperAppDlg.js
Line: 492

I'm running FF 3.5.7 with the same filters in ASF that were in 0.9.3.

The filter that my download triggered is:
Filters Domain
All    
= Regexp.
File name
All    
= Regexp.
Local folder


ASF options: "View options when downloading" is set to "Always show". "Use the filters on the menus" and "Remove the timing delay" are checked. Everything else is unchecked. Dynamic folders is disabled.

*edit*: seems it might've been a bad download link

*edit 2*: maybe not - failed again on another torrent link:
http://a.scarywater.net/frostii/%5BFrostii%5D_Nodame_Cantabile_Finale_-_05_%5B423F9F9B%5D.mkv.torrent

IE was able to download it, as well as FF after I uninstalled ASF.
Post #1
Edit
Cyan
Avatar
Feb 14 2010, 11:52 am
Thanks for the report.
I'll try to check what's wrong, but the error doesn't seems to be originated from ASF but from Firefox himself.
I never touched the file Firefox is reporting.
it will be hard to investigate where the error is located in asf :/


Edit :
I just got the error myself with latest 1.0.1
The error appeared after the file explorer asked for a filename and I clicked "Save" to save the file. the download manager didn't start downloading the file.
I don't know what ASF has to do with this, ASF has already ended long time ago when you choose "Save" :/
ASF is only setting the "browser.download.dir" with the path to the folder when the saving window appears, and stop here. When the user select "Ok" from the saving dialog, firefox then read this data to open the file explorer. The file explorer opens to the correct folder, stating ASF worked correctly. If the File explorer is not sending the download to the download Manager, maybe it has nothing to do with ASF.

It seems there is something related to a timeDelay "waiting for the file explorer to disappear before sending the file to download manager", it seems it is sending the data before the explorer disappear, resulting in nothing to send to the download manager.

maybe try un-checking the "remove the delay" option, but it will not work anymore with right-click over "save link as"


I will investigate more, but it might take some time.
Post #2
Edit
w1nder
Avatar
Feb 15 2010, 4:47 am
I think FF sometimes starts pre-downloading in the background while the Save and/or file explorer dialog boxes are still displayed and waiting for the user to click on. Maybe that has something to do with the problem? But in any case, thanks for taking a look at it!
Post #3
Edit
Cyan
Avatar
Feb 15 2010, 12:58 pm
yes, it starts downloading in a system temp folder, using a random name, and when the user accept the download, the temporary file is moved and renamed with filename.part

I don't think it's the problem here, but I can't be sure.



It's totally normal I will look into it. If ASF is really the problem, I can't let it work like this sweat

It is hard to debug though, the problem seems really random on my side, I got it only once. I downloaded tens of files without encountering the error again.

Does it occur often on your side ? Did you find a pattern ?
Like "if domain changed but the same filter is triggered", or "if previous file was canceled" or anything like that ? I didn't find a pattern yet.
Post #4
Edit
w1nder
Avatar
Feb 17 2010, 6:47 am
Nope, I haven't been able to find a pattern.. it doesn't seem to happen very often, either. And even on the same site, it'll happen for some links but not for others. :/
Post #5
Edit / Delete
Pages : [1] Add a reply

Return to top