Presentation Screenshots Download Support Development Forum    
   

Welcome to the Community Forum.

Here you can discuss with other users or with the author, suggest new features, report bugs, ask for filters creation or correction, etc. Select the forum you wish to read or post below :

Forum
Forum > Filters repository > Filter for torrents





3 previous messages, in reverse order :
User info Filter for torrents
Sharky
Avatar
I think I found the problem.

The bug starts happening when I check "Do this automatically for files like this from now on" for .torrent files.

If I set Firefox to display the what do to dialog again, all torrents are saves correctly to Y:. Checkeing the "Do this automatically" option again and only .torrent files are saved correctly, .something.torrent files are not anymore.
 
Sharky
Avatar
Some more info.

Firefox 3.6 English
Windows 7 Ultimate x64
ASF 1.0.1

I've created only 1 filter. Content:
Filters Domain
All    
= Regexp.
File name
All    
= Regexp.
Local folder
If the file doesn't match any filter, save to:
The last folder
This folder:
Use the last folder if the file is from the same domain


----

Downloading file.torrent sets the dialog to Y:\
Downloading file.avi.torrent sets the dialog to R:\

As to the test you suggested I should perform. I cannot do it, since "+ Add or edit a filter" does not appear in the What do to dialog.





 
Cyan
Avatar
Hi,

I tested your filter, and I didn't find any error.
it's working for me.

I checked the source, but didn't find any bug related to your problem.
Maybe another filter located on top of this one in your filter's list is triggered before.

Can you try to download it again, and when the "what firefox should do" dialog, please click on the "+ Add or edit a filter", and check which one is green.


Tell me which one is green.

If no filter is green, there is a problem either with your filters, or with ASF (I will reverif the source again then).


Could you give me a link to the problematic file ?
Did you checked regexp (I think you didn't, else the filter will not work at all)
Did you define a domain name in your filter ?

Thanks